Skype no Fedora 16 64bits

Se você instalou o fedora 64 bits feliz da vida, ficou encantado com o gnome shell, como eu fiquei, e pensava que o skype seria molezinha. bem, resposta errada.

A instalação do skype é tranquila, não precisei instalar dependência alguma, mas instalar é uma coisa, executar é outra completamente diferente…

Mas eu consegui executar com sucesso, vejamos o que eu fiz:

Se você não quiser ler o passo-a-passo vá para o final da página.

Primeiro precisa obter o erro.

Se você executar no terminal terá uma evidência do por que o skype não funciona assim:

$skype
bash: /usr/bin/skype: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

Que feio! isso significa que o skype procurou a biblioteca de execução e não encontrou! Façamos ele encontrar, como root:

#yum install glibc.i686

Então:

$skype
skype: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory

WTF! outra dependecia quebrada! Perceba que isso vai ficando chato!

Mas o yum é fera, assim vamos catar quem prove esse danado do libasound.so.2:

#yum whatprovides libasound.so.2
alsa-lib-1.0.24-2.fc15.i686 : The Advanced Linux Sound Architecture (ALSA) library
Repo        : fedora
Matched from:
Other       : libasound.so.2

Lindo! o alsa-lib 32 bits! Mas… será que são somente essas bibliotecas quebradas? quantas vezes vou ter que executar linha por linha? Evoquemos o ldd!

$ldd  ` which skype`
    linux-gate.so.1 =>  (0x001da000)
    libasound.so.2 => not found
    libXv.so.1 => not found
    libXss.so.1 => not found
    librt.so.1 => /lib/librt.so.1 (0x00d1f000)
    libQtDBus.so.4 => not found
    libQtGui.so.4 => not found
    libQtNetwork.so.4 => not found
    libQtCore.so.4 => not found
    libpthread.so.0 => /lib/libpthread.so.0 (0x00984000)
    libstdc++.so.6 => not found
    libm.so.6 => /lib/libm.so.6 (0x00766000)
    libgcc_s.so.1 => not found
    libc.so.6 => /lib/libc.so.6 (0x001db000)
    libdl.so.2 => /lib/libdl.so.2 (0x007b3000)
    /lib/ld-linux.so.2 (0x008ed000)
    libX11.so.6 => not found
    libXext.so.6 => not found

O comando ldd “lista” as bibliotecas dinâmicas do qual o skype foi compilado. o comando which calcula qual o caminho completo para o skype.

Bom, vamos pegar todos os resultados que não foram encontrados e buscar os pacotes que os proveem.

Para o meu caso:

yum provides libasound.so.2 libXv.so.1 libXss.so.1 libQtDBus.so.4 libQtGui.so.4 libQtNetwork.so.4 libQtCore.so.4 libstdc++.so.6  libgcc_s.so.1 libX11.so.6 libXext.so.6

E os seguintes pacotes foram listados:

alsa-lib-1.0.24-2.fc15.i686 libXv-1.0.6-2.fc15.i686 libXScrnSaver-1.2.1-2.fc15.i686  qt-4.8.0-5.fc16.i686 qt-x11-4.8.0-5.fc16.i686 libstdc++-4.6.2-1.fc16.i686 libgcc-4.6.2-1.fc16.i686  libX11-1.4.3-1.fc16.i686 libXext-1.3.0-1.fc16.i686

Assim:

yum install  alsa-lib.i686 libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686  libstdc++.i686 libX11.i686 libXext.i686

Respire fundo, que o yum vai calcular as dependencias e fazer a mágica para você

Findo,

skype
Funcionou de primeira.

Em resumo o que você precisa fazer é:

yum install glibc.i686 alsa-lib.i686 libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686  libstdc++.i686 libX11.i686 libXext.i686

Os resultados podem variar de acordo com o que você tem instalado na sua máquina. Mas o básico é isso ai…

Fonte: Site Rômulo Jales

Anúncios

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s